LAX100 Chiller Status
Incident Report for QuadraNet
Resolved
This incident has been resolved.
Posted Apr 22, 2022 - 19:45 PDT
Identified
We are currently experiencing a fault with our chiller system and we have engaged our chiller vendor to perform an emergency dispatch to rectify the issue. We anticipate the vendors will arrive at approximately 6:30PM PST
Posted Apr 22, 2022 - 18:21 PDT
This incident affected: LAX Century.